Atom SDK Stuck In Blank Page At Startup

Post Reply
User avatar
Posts: 18
Joined: Sun Mar 31, 2019 4:01 pm

Atom SDK Stuck In Blank Page At Startup

Post by fixed1t » Tue Apr 09, 2019 11:40 am

Arthur and I had a issue with the ATOM SDK Installations, he had a perfectly working Atom SDK kit on his PC and an old Mac but It wouldn't run on my Mac as it got stuck at a blank Jibo Electron window when I started ATOM. Arthur then spent hours remotely on my new PC as I'm in the UK several time zones away and each time we hit the same brick wall. In my attempts to better understand the issues, I decide to load Jibo SDK 1.6.3 instead of 1.7.1 and when Atom started, it popped up with a Login Window stating it was looking for early adopters details. I figured out the errors were possibly down to code checks on the Early Adopters details at login i.e. If you were an early adopter then you had legacy passwords and details on your machine (therefore it worked) but if you weren't you were stuck. I was then able to trace it to the gating/login module before sending my ideas to Arthur and heading to bed and 01:30. Thanks to the time-zone difference Arthur was able to track it further and come up with a solution (Well Done Arthur for the gargantuan efforts) and I installed his patched jibo-sdk.js overwriting the one in the .ATOM directory it worked. Jibo-sdl 1.6.3 was working, so pushing my luck I re-installed 1.7.1 and applied the patch and its all working great.

I'm really pleased.

Thanks Arthur for the incredible work you've put into this.

Other good news, my Nvidia TX1 Developer Kit (Its has the main cpu/gpu that Jibo was based on on the development board) also arrived so I will be setting it up over the next few days and running some tests before flashing it with Jibo as his second home, so I can better understand what he's doing at an assembler and component level.

Malcolm aka @fixed1t

Post Reply